summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-14 10:35:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:58 +0200
commit89b54d1ea8f56bed39fe4d2480825d01da8efcde (patch)
tree0c5c5c5701a872f2b8c98b52f352c5d4f3575418 /gnu
parent6734cfd2b7a86e005730e46f8b146f744a317eee (diff)
downloadguix-89b54d1ea8f56bed39fe4d2480825d01da8efcde.tar.gz
gnu: texlive-latex-acmart -> texlive-acmart.
* gnu/packages/tex.scm (texlive-acmart): New variable.
(texlive-latex-acmart): Deprecate variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm54
1 files changed, 42 insertions, 12 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2b50e35a15..e445a93ea5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8239,26 +8239,56 @@ technical illustrations.  Its output is scalable PostScript or SVG, rather
 than the bitmaps Metafont creates.")
     (license license:lppl)))
 
-(define-public texlive-latex-acmart
+(define-public texlive-acmart
   (package
-    (name "texlive-latex-acmart")
-    (version "1.60")
-    (source (origin
-              (method svn-fetch)
-              (uri (texlive-ref "latex" "acmart"))
-              (sha256
-               (base32
-                "12wxav9r6v7dlfja9myrwz7famgfpcfwd292qzmgg283xgngh9kd"))
-              (file-name (string-append name "-" version "-checkout"))))
+    (name "texlive-acmart")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "bibtex/bst/acmart/" "doc/latex/acmart/"
+                   "source/latex/acmart/" "tex/latex/acmart/")
+             (base32
+              "0vz0dla2frf5wgp5xrqc9q4z730k9wayfkfj0vg58a2xjriarrzn")))
+    (outputs '("out" "doc"))
     (build-system texlive-build-system)
-    (arguments '(#:tex-directory "latex/acmart"))
-    (home-page "https://www.ctan.org/pkg/acmart")
+    (propagated-inputs
+     (list texlive-booktabs
+           texlive-caption
+           texlive-cmap
+           texlive-comment
+           texlive-draftwatermark
+           texlive-environ
+           texlive-etoolbox
+           texlive-fancyhdr
+           texlive-float
+           texlive-geometry
+           texlive-graphics
+           texlive-hyperref
+           texlive-hyperxmp
+           texlive-iftex
+           texlive-inconsolata
+           texlive-libertine
+           texlive-microtype
+           texlive-natbib
+           texlive-ncctools
+           texlive-newtx
+           texlive-preprint
+           texlive-refcount
+           texlive-setspace
+           texlive-textcase
+           texlive-totpages
+           texlive-xcolor
+           texlive-xkeyval
+           texlive-xstring))
+    (home-page "https://ctan.org/pkg/acmart")
     (synopsis "Class for typesetting publications of ACM")
     (description
      "This package provides a class for typesetting publications of the
 Association for Computing Machinery (ACM).")
     (license license:lppl1.3+)))
 
+(define-deprecated-package texlive-latex-acmart texlive-acmart)
+
 (define-public texlive-latex-varwidth
   (package
     (name "texlive-latex-varwidth")