summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-11-08 19:16:48 -0500
committerLeo Famulari <leo@famulari.name>2017-11-08 19:32:32 -0500
commit8f220b7b41f47d1a8d1c60366bde4415b59de9f8 (patch)
tree8be8ffcddd93db1891a9c01f6eb0279c85df0e99 /gnu
parentea1f073d73f9122865368bfe5cfa96f978998541 (diff)
downloadguix-8f220b7b41f47d1a8d1c60366bde4415b59de9f8.tar.gz
gnu: tremc: Update to 0.9.0-1.9755b50.
* gnu/packages/bittorrent.scm (tremc): Update to 0.9.0-1.9755b50.
[version]: Use git-version.
[source]: Use git-file-name.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bittorrent.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 90cedb6568..9fbe0ce562 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -177,20 +177,21 @@ XML-RPC over SCGI.")
     (license l:gpl2+)))
 
 (define-public tremc
-  (let ((commit "401f2303c9b5a6e2e7b0808617d794576d4aa29e")
-        (revision "0"))
+  (let ((commit "9755b50e9444566cff02c977edafdbb3e9750cbb")
+        (revision "1"))
     (package
       (name "tremc")
-      (version (string-append "0.9.0-" revision "." (string-take commit 7)))
+      (version (git-version "0.9.0" revision commit))
       (source
         (origin
           (method git-fetch)
           (uri (git-reference
                  (url "https://github.com/louipc/tremc.git")
                  (commit commit)))
+          (file-name (git-file-name name version))
           (sha256
            (base32
-            "1h2720zn35iggmf9av65g119b0bhskwm1ng0zbkjryaf38nfzpin"))))
+            "05259qss5jka5ygwrh7cngyp6cgazbynji5pshgfzrd2d43pyfq5"))))
       (build-system python-build-system)
       (arguments
        `(#:tests? #f ; no test suite