summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-01-28 20:58:57 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-02-24 20:01:30 +0300
commit9b993e3bb92382422896471d821a32fb7b54bb19 (patch)
tree58752e6508d4803d5a4d26cdfd7342d6701fbbff /gnu
parent017b014ce4a5defed12836886c4dfe2c5ae89d2d (diff)
downloadguix-9b993e3bb92382422896471d821a32fb7b54bb19.tar.gz
gnu: Add perl-b-hooks-op-check.
* gnu/packages/perl.scm (perl-b-hooks-op-check): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 397a77b217..13252d656f 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -410,6 +410,27 @@ all known commands are checked.")
 compiling the surrounding scope.")
     (license (package-license perl))))
 
+(define-public perl-b-hooks-op-check
+  (package
+    (name "perl-b-hooks-op-check")
+    (version "0.22")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/E/ET/ETHER/B-Hooks-OP-Check-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "1kfdv25gn6yik8jrwik4ajp99gi44s6idcvyyrzhiycyynzd3df7"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-extutils-depends" ,perl-extutils-depends)))
+    (home-page "http://search.cpan.org/dist/B-Hooks-OP-Check/")
+    (synopsis "Wrap OP check callbacks")
+    (description "This module allows you to wrap OP check callbacks.")
+    (license (package-license perl))))
+
 (define-public perl-b-keywords
   (package
     (name "perl-b-keywords")