summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2022-11-26 18:27:27 -0800
committerTobias Geerinckx-Rice <me@tobias.gr>2022-11-27 01:00:00 +0100
commit9ef6286bc3f6ed780606d3c2089aed7ff73074c3 (patch)
tree11f83ea6c87fc5603fca4551542dafdf0c2ec756 /gnu
parent83350bf56b20f3106cd9eeab80b70a9eaf810a48 (diff)
downloadguix-9ef6286bc3f6ed780606d3c2089aed7ff73074c3.tar.gz
gnu: Add bgpq3.
* gnu/packages/networking.scm (bgpq3): New variable.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f5276e330e..751eb2b867 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2998,6 +2998,40 @@ updates to the zebra daemon.")
     (home-page "https://www.nongnu.org/quagga/")
     (license license:gpl2+)))
 
+(define-public bgpq3
+  (package
+    (name "bgpq3")
+    (version "0.1.36.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/snar/bgpq3")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0768hihx7idmn2dk8ii21m0dm052amlnfpqq53vsfaapb60n1smc"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:tests? #f))                    ; no test suite
+    (native-inputs (list python-markdown))
+    (home-page "http://snar.spb.ru/prog/bgpq3/")
+    (synopsis
+     "Generate BGP filters from the @acronym{IRR, Internet Routing Registry}")
+    (description
+     "This program helps automate the creation and maintenance of @acronym{BGP,
+Border Gateway Protocol} routing filters used for peering trough Internet
+exchanges.
+
+It generates prefix lists, (extended) access lists, policy-statement terms, and
+AS paths from data in the @acronym{IRR, Internet Routing Registry}, including
+the @acronym{RADB, Routing Assets Database} operated by the Merit Network at the
+University of Michigan.
+
+The filters can be aggregated and exported in the most common formats.")
+    (license (list license:bsd-3        ; strlcpy.c, sys_queue.h
+                   license:bsd-2))))    ; everything else, but missing headers
+
 (define-public thc-ipv6
   (let ((revision "0")
         (commit "4bb72573e0950ce6f8ca2800a10748477020029e"))