summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-29 12:45:46 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-12 20:51:23 -0400
commita0a0c282f06ec7de3a1bb514e17cd32e8eb154a3 (patch)
tree7b321faf25d56632a43d6f245a5d08bb207c101a /gnu
parent8784bbd510c08991b47cd1141ce222b0ad9c92dc (diff)
downloadguix-a0a0c282f06ec7de3a1bb514e17cd32e8eb154a3.tar.gz
gnu: Add gi-docgen.
* gnu/packages/gnome.scm (gi-docgen): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ce9406a8b9..6b912ddc8c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -186,6 +186,7 @@
   #:use-module (gnu packages protobuf)
   #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-build)
   #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
@@ -5079,6 +5080,32 @@ and other secrets.  It communicates with the \"Secret Service\" using DBus.")
  Try to last as long as possible.")
     (license license:gpl2+)))
 
+(define-public gi-docgen
+  (package
+    (name "gi-docgen")
+    (version "2022.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "gi-docgen" version))
+              (sha256
+               (base32
+                "1v2wspm2ld27lq1n5v5pzrmkhchfa7p7ahp8rmjm4zcdyagqf7gr"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-jinja2
+                             python-markdown
+                             python-markupsafe
+                             python-pygments
+                             python-toml
+                             python-typogrify))
+    (home-page "https://gitlab.gnome.org/GNOME/gi-docgen")
+    (synopsis "Documentation tool for GObject-based libraries")
+    (description "GI-DocGen is a document generator for GObject-based
+libraries.  GObject is the base type system of the GNOME project.  GI-Docgen
+reuses the introspection data generated by GObject-based libraries to generate
+the API reference of these libraries, as well as other ancillary
+documentation.")
+    (license license:gpl3+)))
+
 (define-public gnome-mines
   (package
     (name "gnome-mines")