summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-07-24 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-07-24 02:00:26 +0200
commita2bd3758c14b05038c861419b6b6816379514620 (patch)
tree6a88c517ec0a4eb60b47f3fe334063a44bdca8a8 /gnu
parent54c6e3918805879bf04dec9c397ca622b66e52f9 (diff)
downloadguix-a2bd3758c14b05038c861419b6b6816379514620.tar.gz
gnu: console-setup: Clean up #:make-flags.
* gnu/packages/xorg.scm (console-setup)[arguments]: Properly
set #:make-flags once.  Use them across all phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm27
1 files changed, 9 insertions, 18 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 6ba5c32dcb..ff633a192c 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6586,9 +6586,9 @@ output.")
     (build-system gnu-build-system)
     (arguments
      '(#:make-flags
-       (let ((bash (assoc-ref %build-inputs "bash"))
-             (out (assoc-ref %outputs "out")))
-         (list (string-append "SHELL=" bash "/bin/bash")))
+       (list (string-append "SHELL=" (assoc-ref %build-inputs "bash")
+                            "/bin/bash")
+             (string-append "prefix=" (assoc-ref %outputs "out")))
        #:tests? #f                      ; no tests
        #:phases
        (modify-phases %standard-phases
@@ -6601,22 +6601,13 @@ output.")
                (("\"cat ")
                 (format #f "\"~a " (search-input-file inputs "bin/cat"))))))
          (add-before 'build 'make-doubled-bdfs
-           (lambda* (#:key native-inputs inputs #:allow-other-keys)
-             (invoke "make" "-C" "Fonts"
-                     "doubled_bdfs"
-                     (string-append "SHELL="
-                                    (assoc-ref (or native-inputs inputs)
-                                               "bash")
-                                    "/bin/bash"))))
+           (lambda* (#:key make-flags #:allow-other-keys)
+             (apply invoke "make" "-C" "Fonts" "doubled_bdfs"
+                    make-flags)))
          (replace 'install
-           (lambda* (#:key native-inputs inputs outputs #:allow-other-keys)
-             (let ((out (assoc-ref %outputs "out")))
-               (invoke "make" "install-linux"
-                       (string-append "prefix=" out)
-                       (string-append "SHELL="
-                                      (assoc-ref (or native-inputs inputs)
-                                                 "bash")
-                                      "/bin/bash"))))))))
+           (lambda* (#:key make-flags #:allow-other-keys)
+             (apply invoke "make" "install-linux"
+                    make-flags))))))
     (native-inputs
      (list pkg-config
            bdftopcf