summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-01-28 01:58:44 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-02-24 20:01:30 +0300
commita4e6bf64f7570aee5bc3393c24fa3c3dae8c228d (patch)
tree58042b0905d60e339657d8360ed1bd8085be06e0 /gnu
parent12d330b0a40dc90a9c8ccbc80e47fd602e77628e (diff)
downloadguix-a4e6bf64f7570aee5bc3393c24fa3c3dae8c228d.tar.gz
gnu: Add perl-data-section.
* gnu/packages/perl.scm (perl-data-section): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 056acbb71f..6a2ebbaa41 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1813,6 +1813,32 @@ an \"unless\" regular expression.  If the text in question matches the
 like split on newlines unless newlines are embedded in quotes.")
     (license (package-license perl))))
 
+(define-public perl-data-section
+  (package
+    (name "perl-data-section")
+    (version "0.200007")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/R/RJ/RJBS/Data-Section-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1pmlxca0a8sv2jjwvhwgqavq6iwys6kf457lby4anjp3f1dpx4yd"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-test-failwarnings" ,perl-test-failwarnings)))
+    (propagated-inputs
+     `(("perl-mro-compat" ,perl-mro-compat)
+       ("perl-sub-exporter" ,perl-sub-exporter)))
+    (home-page "http://search.cpan.org/dist/Data-Section/")
+    (synopsis "Read multiple hunks of data out of your DATA section")
+    (description "This package provides a Perl library to read multiple hunks
+of data out of your DATA section.")
+    (license (package-license perl))))
+
 (define-public perl-data-stag
   (package
     (name "perl-data-stag")