summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-14 21:11:04 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:05 +0200
commitc0b892b696473213754f34f7d58158cc0db2f51c (patch)
treedc28796d0185663f0ef84c38cad3f1aaf8789aa7 /gnu
parent55aa692e2266a0a941c25ccdcfc8c1a41c5246d6 (diff)
downloadguix-c0b892b696473213754f34f7d58158cc0db2f51c.tar.gz
gnu: Add texlive-regexpatch.
* gnu/packages/tex.scm (texlive-regexpatch): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2321bfb096..cf4d150de9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3849,6 +3849,32 @@ arrows; record information about document class(es) used; and many more.")
 
 (define-deprecated-package texlive-latex-oberdiek texlive-oberdiek)
 
+(define-public texlive-regexpatch
+  (package
+    (name "texlive-regexpatch")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/regexpatch/"
+                   "source/latex/regexpatch/"
+                   "tex/latex/regexpatch/")
+             (base32
+              "1jv8hvkvq0yvc8mh68ybj8fvhf6kcdzwjin1czs45i26s0dpsngj")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-l3kernel
+           texlive-l3packages))
+    (home-page "https://ctan.org/pkg/regexpatch")
+    (synopsis "High level patching of commands")
+    (description
+     "The package generalises the macro patching commands provided by
+P. Lehmann's @code{etoolbox}.  The difference between this package and its
+sibling @code{xpatch} is that this package sports a very powerful
+@code{\\regexpatchcmd} based on the @code{l3regex} module of the LaTeX3
+experimental packages.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-rerunfilecheck
   (let ((template (simple-texlive-package
                    "texlive-rerunfilecheck"