summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-02-22 19:50:47 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-02-22 20:14:15 +0100
commitcc13c85c4af0bdf95bd36c6b63b21c70d3a5a319 (patch)
tree139403f053a407006dfa20c532556d291e28e413 /gnu
parentc8f1781eb16d3275f01d274c656f63d76f746ec4 (diff)
downloadguix-cc13c85c4af0bdf95bd36c6b63b21c70d3a5a319.tar.gz
gnu: Add r-cccd.
* gnu/packages/cran.scm (r-cccd): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ae8911f4c0..5665b44f4d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -32082,6 +32082,26 @@ least four days in the calendar year.  This package provides functionality to
 convert dates to MMWR day, week, and year and the reverse.")
     (license license:gpl2+)))
 
+(define-public r-cccd
+  (package
+    (name "r-cccd")
+    (version "1.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "cccd" version))
+       (sha256
+        (base32 "0m364zsrgr7mh1yhl2lqxpaf71gzq3y3pp9qgnj4spiy4iadyy7i"))))
+    (properties `((upstream-name . "cccd")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-deldir r-fnn r-igraph r-proxy))
+    (home-page "https://cran.r-project.org/package=cccd")
+    (synopsis "Class cover catch digraphs")
+    (description
+     "This package provides tools to create Class Cover Catch Digraphs,
+neighborhood graphs, and relatives.")
+    (license license:gpl2+)))
+
 (define-public r-crul
   (package
     (name "r-crul")