summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-02 09:03:07 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-07-20 10:11:26 +0200
commitd4306847bf8736bf60a2ff435fd2d8ef763f769c (patch)
tree656955075a4befa8b62c9d46e9e4247edfcd2912 /gnu
parentcf1216d8763adf3c5e9d79d7abd2c5ecc8861d60 (diff)
downloadguix-d4306847bf8736bf60a2ff435fd2d8ef763f769c.tar.gz
Revert "gnu: libunistring: Fix make check for the Hurd."
This reverts commit 12e6a5923812abf180f03bea9e07dd99244a3fcd, which used
XFAIL_TESTS to have 'make check' pass with failing tests "test-perror2"
"test-strerror_r" that now pass with glibc-2.37 and libc-for-target in
commencement.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/libunistring.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/libunistring.scm b/gnu/packages/libunistring.scm
index e68b7d2378..eccd053a35 100644
--- a/gnu/packages/libunistring.scm
+++ b/gnu/packages/libunistring.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016, 2018, 2022 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -28,7 +28,6 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix gexp)
-  #:use-module (guix utils)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
   #:use-module (gnu packages base))
@@ -61,10 +60,7 @@
               (with-directory-excursion (string-append #$output "/lib")
                 (install-file "libunistring.a"
                               (string-append #$output:static "/lib"))
-                (delete-file "libunistring.a")))))
-      #:make-flags (if (target-hurd?)
-                       #~(list "XFAIL_TESTS=test-perror2 test-strerror_r")
-                       #~'())))
+                (delete-file "libunistring.a")))))))
    (synopsis "C library for manipulating Unicode strings")
    (description
     "GNU libunistring is a library providing functions to manipulate