summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2019-11-28 19:16:41 +0100
committerLudovic Courtès <ludo@gnu.org>2019-12-04 18:16:08 +0100
commitd75540473f3f460007f45efab5122c39aa4130ff (patch)
treec2d54a02f5bba2ba7caa2b7a3370a78bf1efd4b3 /gnu
parentfe7b59c6b1200fcc10bda954c2370eca63af5299 (diff)
downloadguix-d75540473f3f460007f45efab5122c39aa4130ff.tar.gz
gnu: bitlbee: Use Python 3.
* gnu/packages/messaging.scm (bitlbee)[inputs]: Replace python-2 with python.
[arguments]: Set the PYTHON environment variable before configuring.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/messaging.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 73c7620d4e..27d2b7689c 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -17,6 +17,7 @@
 ;;; Copyright © 2018 Pierre-Antoine Rouby <contact@parouby.fr>
 ;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
+;;; Copyright © 2019 Timotej Lazar <timotej.lazar@araneo.si>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -185,11 +186,13 @@ end-to-end encryption.")
     (inputs `(("glib" ,glib)
               ("libotr" ,libotr)
               ("gnutls" ,gnutls)
-              ("python" ,python-2)
+              ("python" ,python)
               ("perl" ,perl)))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-before 'configure 'set-python
+           (lambda _ (setenv "PYTHON" (which "python3")) #t))
          (add-after 'install 'install-etc
            (lambda* (#:key (make-flags '()) #:allow-other-keys)
              (apply invoke "make" "install-etc" make-flags)))