summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorZzull <bstrazzull@hotmail.fr>2022-09-24 17:42:28 +0200
committerLudovic Courtès <ludo@gnu.org>2022-10-04 18:15:36 +0200
commitd7932b731f0a3b396c6b2503a461a21a474098c3 (patch)
treeb99eb019e41a068b52ae055038abceaea83cf0f9 /gnu
parent0669bf64f788a6fe8567f4ae16c022583df1a5f8 (diff)
downloadguix-d7932b731f0a3b396c6b2503a461a21a474098c3.tar.gz
gnu: Add python-executor.
* gnu/packages/python-xyz.scm (python-executor): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9f0275cb68..8575d4a67e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7343,6 +7343,32 @@ writable properties, cached properties, etc.")
 currently doing, particularly the AST node being executed.")
     (license license:expat)))
 
+(define-public python-executor
+  (package
+    (name "python-executor")
+    (version "23.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "executor" version))
+       (sha256
+        (base32 "0g83yr54j0vcwhy6h7n0jsd7q0q630kwa6v9kqzlzrm9xj6c3ip1"))))
+    (build-system python-build-system)
+    (arguments
+    `(#:tests? #f)) ; TODO: tests require root/sudo
+    (propagated-inputs
+     (list python-six
+           python-property-manager
+           python-fasteners
+           python-virtualenv))
+    (home-page "https://github.com/xolox/python-executor")
+    (synopsis "Programmer friendly subprocess wrapper")
+    (description "The @code{executor} package is a simple wrapper for Python’s
+subprocess module that makes it very easy to handle subprocesses on UNIX
+systems with proper escaping of arguments and error checking currently doing,
+particularly the AST node being executed.")
+    (license license:expat))) ; MIT license
+
 (define-public python-roifile
   (package
     (name "python-roifile")