summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-04 21:40:55 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-04 21:40:55 +0200
commitd7c8cb7e53682a52a80bd35e2deaaab7f3e0c912 (patch)
treefec4f08d33a1c98cfa0be4fffcec3533c5332864 /gnu
parent093014dd2f1569806d70b89084afc8e330891094 (diff)
downloadguix-d7c8cb7e53682a52a80bd35e2deaaab7f3e0c912.tar.gz
gnu: Remove rust-rust-crypto-0.2.
* gnu/packages/crates-io.scm (rust-rust-crypto-0.2): Delete variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index af3409d198..487befa965 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -13994,34 +13994,6 @@ all the formatting features of the format! macro, except for the fill
 character.")
     (license license:asl2.0)))
 
-(define-public rust-rust-crypto-0.2
-  (package
-    (name "rust-rust-crypto")
-    (version "0.2.36")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "rust-crypto" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0aias7gh2ypj4skmh6hfsjli4fhnvcvf9s1ljjpz9m9zk79havgp"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-gcc" ,rust-gcc-0.3)
-        ("rust-libc" ,rust-libc-0.2)
-        ("rust-rand" ,rust-rand-0.3)
-        ("rust-rustc-serialize" ,rust-rustc-serialize-0.3)
-        ("rust-time" ,rust-time-0.1))))
-    (home-page "https://github.com/DaGenix/rust-crypto/")
-    (synopsis "Mostly pure-Rust implementation of various cryptographic algorithms")
-    (description
-     "This package provides a (mostly) pure-Rust implementation of various
-common cryptographic algorithms.")
-    (license (list license:expat license:asl2.0))))
-
 (define-public rust-rusticata-macros-4
   (package
     (name "rust-rusticata-macros")