summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPeter Lo <peterloleungyau@gmail.com>2020-06-28 17:29:43 +0800
committerRicardo Wurmus <rekado@elephly.net>2020-09-11 11:02:12 +0200
commitd89a65e65368e782df344608722e66d83e23da32 (patch)
treec7bf10d9504e145089ab2717f7f7ac1400f52f9b /gnu
parent466ccbcad620507bea46ed6fbff483f25aebd403 (diff)
downloadguix-d89a65e65368e782df344608722e66d83e23da32.tar.gz
gnu: Add r-maxstat.
* gnu/packages/cran.scm (r-maxstat): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 996d61db2f..f6fea1885f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -23495,3 +23495,26 @@ the @code{survival} package.")
      "This package computes exact conditional p-values and quantiles using an
 implementation of the Shift-Algorithm by Streitberg & Roehmel.")
     (license license:gpl2+)))
+
+(define-public r-maxstat
+  (package
+    (name "r-maxstat")
+    (version "0.7-25")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "maxstat" version))
+       (sha256
+        (base32
+         "114z1rwxwvk05ijjhdppzm148n1h192fp0w12ky10zkrhf6kphbg"))))
+    (properties `((upstream-name . "maxstat")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-exactranktests" ,r-exactranktests)
+       ("r-mvtnorm" ,r-mvtnorm)))
+    (home-page "https://cran.r-project.org/web/packages/maxstat/")
+    (synopsis "Maximally selected rank statistics")
+    (description
+     "This package provides maximally selected rank statistics with several
+p-value approximations.")
+    (license license:gpl2+)))