summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRaphaël Mélotte <raphael.melotte@mind.be>2021-05-18 18:49:40 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-22 23:37:24 +0200
commitd900cbadfd03fdfca155531bf3b2f5b548582c65 (patch)
tree4b22b649937d120eaab56e641837269715ef3a1e /gnu
parentbc4d81d267830a3b1ccb63198f4100cc836e4e4e (diff)
downloadguix-d900cbadfd03fdfca155531bf3b2f5b548582c65.tar.gz
gnu: luakit: Update to 2.3.
* gnu/packages/web-browsers.scm (luakit): Update to 2.3
[arguments]: Add 'set-version' phase.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web-browsers.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index af178f9092..f677d58fd6 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -231,7 +231,7 @@ features including, tables, builtin image display, bookmarks, SSL and more.")
 (define-public luakit
   (package
     (name "luakit")
-    (version "2.2")
+    (version "2.3")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -240,7 +240,7 @@ features including, tables, builtin image display, bookmarks, SSL and more.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0km5nxn6innzn8pfsvlkxvfj2z5g46fp6dy5bnmaklbn13mqlcrn"))))
+                "1khbn7dpizkznnwkw7rcfhf72dnd1nazk7dwb4rkh9i97b53mf1y"))))
     (inputs
      `(("lua-5.1" ,lua-5.1)
        ("gtk+" ,gtk+)
@@ -254,7 +254,7 @@ features including, tables, builtin image display, bookmarks, SSL and more.")
      `(("pkg-config" ,pkg-config)))
     (build-system glib-or-gtk-build-system)
     (arguments
-     '(#:make-flags
+     `(#:make-flags
        (let ((out (assoc-ref %outputs "out")))
          (list
           "CC=gcc"
@@ -271,6 +271,10 @@ features including, tables, builtin image display, bookmarks, SSL and more.")
                       (assoc-ref %build-inputs "lua5.1-filesystem")
                       "/lib/lua/5.1/?.so;;"))
              #t))
+         (add-before 'build 'set-version
+           (lambda _
+             (setenv "VERSION_FROM_GIT" ,(package-version this-package))
+             #t))
          (delete 'configure)
          (delete 'check)
          (add-after 'install 'wrap