summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-02-08 23:40:31 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-02-09 09:02:24 +0100
commite193a74337e78d5ea23f9ccec0e553ae1c3ce3e5 (patch)
tree7474c04dd2bd1ad3ee13a53e458846c97bb8be74 /gnu
parentbc54947410689cc752ca962b0b4d27fa799265bf (diff)
downloadguix-e193a74337e78d5ea23f9ccec0e553ae1c3ce3e5.tar.gz
gnu: Add r-gghighlight.
* gnu/packages/cran.scm (r-gghighlight): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index dc83823b6c..84abc75ecd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22881,6 +22881,30 @@ finding peaks in spectra, converting humidity measures.")
 from PLINK results.")
     (license license:gpl3)))
 
+(define-public r-gghighlight
+  (package
+    (name "r-gghighlight")
+    (version "0.3.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "gghighlight" version))
+       (sha256
+        (base32 "0bxgn4srxz1qhawqa8ck57p8hg5ikwfa9ll03zmnn8fb19akwm2v"))))
+    (properties `((upstream-name . "gghighlight")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-dplyr r-ggplot2 r-ggrepel r-lifecycle r-purrr r-rlang r-tibble))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/yutannihilation/gghighlight/")
+    (synopsis "Highlight lines and points in ggplot2")
+    (description "Suppose we have data that has so many series that it is hard
+to identify them by their colors as the differences are so subtle.  With
+gghighlight we can highlight those lines that match certain criteria.  The
+result is a usual @code{ggplot} object, so it is fully customizable and can be
+used with custom themes and facets.")
+    (license license:expat)))
+
 (define-public r-ggplot-multistats
   (package
     (name "r-ggplot-multistats")