summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-09 22:28:28 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-10 19:27:07 +0200
commite43ceae59f4b7e69fea25f8242db9073fab06f48 (patch)
tree011f40669c6f8f80ee6288f3f333fbd2e5cfc2f5 /gnu
parente652b44725d910169f0281f04d447074512efca1 (diff)
downloadguix-e43ceae59f4b7e69fea25f8242db9073fab06f48.tar.gz
gnu: Add python-deepdiff.
* gnu/packages/python-xyz.scm (python-deepdiff): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4f48d80eb6..74103403bb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31645,6 +31645,34 @@ development but it can be used for all sorts of general purpose parsing.")
 object, which can be useful if you want to force your objects into a table.")
     (license license:expat)))
 
+(define-public python-deepdiff
+  (package
+    (name "python-deepdiff")
+    (version "6.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "deepdiff" version))
+              (sha256
+               (base32
+                "0i5nnb3nppi2vgbhiakpxiagyhx7l1f50hzcl8fcgica4bkz2fva"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-ordered-set))
+    (native-inputs
+     (list python-click
+           python-dateutil
+           python-jsonpickle
+           python-mock
+           python-numpy
+           python-pytest
+           python-pyyaml))
+    (home-page "https://github.com/seperman/deepdiff")
+    (synopsis "Deep difference and search of any Python object/data")
+    (description
+     "This package provides tools for computing deep differences and searching
+of any Python object/data.  Recreate objects by adding adding deltas to each
+other.")
+    (license license:expat)))
+
 (define-public python-deepmerge
   (package
     (name "python-deepmerge")