summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-06-08 11:03:31 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-14 11:17:00 +0200
commitea0a06cee2ba05451f94714a4f913db02efbe92c (patch)
tree8447b4531818371310470446a17f77d313bb991a /gnu
parentdf2f6400b1fbc282ef4d6dd7124ea1c17adc23c2 (diff)
downloadguix-ea0a06cee2ba05451f94714a4f913db02efbe92c.tar.gz
Remove 'guix-register' and its traces.
* Makefile.am (SH_TESTS): Remove tests/guix-register.sh.
* build-aux/pre-inst-env.in (GUIX_REGISTER): Remove.
* gnu/build/install.scm (directives): Remove outdated comment.
* gnu/build/vm.scm (root-partition-initializer): Update comment.
* gnu/packages/package-management.scm (guix-register): Remove.
* guix/config.scm.in (%sbindir, %guix-register-program): Remove.
* guix/scripts/system.scm (install): Adjust docstring.
* guix/self.scm (make-config.scm): Remove #:guix.  Do not generate
%sbindir and %guix-register-program.
(specification->package): Remove "guix".
* nix/guix-register/guix-register.cc: Remove.
* nix/libstore/store-api.cc (decodeValidPathInfo): Remove.
* nix/libstore/store-api.hh (decodeValidPathInfo): Remove declaration.
* nix/local.mk (sbin_PROGRAMS, guix_register_SOURCES)
(guix_register_CPPFLAGS, guix_register_LDFLAGS): Remove.
* tests/guix-register.sh: Remove.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/build/install.scm3
-rw-r--r--gnu/build/vm.scm4
-rw-r--r--gnu/packages/package-management.scm36
3 files changed, 2 insertions, 41 deletions
diff --git a/gnu/build/install.scm b/gnu/build/install.scm
index 06ecb39952..5a5e703872 100644
--- a/gnu/build/install.scm
+++ b/gnu/build/install.scm
@@ -110,9 +110,6 @@ STORE."
 
     ("/var/guix/gcroots/booted-system" -> "/run/booted-system")
     ("/var/guix/gcroots/current-system" -> "/run/current-system")
-
-    ;; XXX: 'guix-register' creates this symlink with a wrong target, so
-    ;; create it upfront to be sure.
     ("/var/guix/gcroots/profiles" -> "/var/guix/profiles")
 
     (directory "/bin")
diff --git a/gnu/build/vm.scm b/gnu/build/vm.scm
index 803cd5996a..73d0191de7 100644
--- a/gnu/build/vm.scm
+++ b/gnu/build/vm.scm
@@ -346,7 +346,7 @@ SYSTEM-DIRECTORY is the name of the directory of the 'system' derivation."
     ;; Optionally, register the inputs in the image's store.
     (when register-closures?
       (unless copy-closures?
-        ;; XXX: 'guix-register' wants to palpate the things it registers, so
+        ;; XXX: 'register-closure' wants to palpate the things it registers, so
         ;; bind-mount the store on the target.
         (mkdir-p target-store)
         (mount (%store-directory) target-store "" MS_BIND))
@@ -365,7 +365,7 @@ SYSTEM-DIRECTORY is the name of the directory of the 'system' derivation."
     (display "populating...\n")
     (populate-root-file-system system-directory target)
 
-    ;; 'guix-register' resets timestamps and everything, so no need to do it
+    ;; 'register-closure' resets timestamps and everything, so no need to do it
     ;; once more in that case.
     (unless register-closures?
       (reset-timestamps target))))
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 786d2a53e9..24cf3ad015 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -294,42 +294,6 @@ the Nix package manager.")
 ;; Alias for backward compatibility.
 (define-public guix-devel guix)
 
-(define-public guix-register
-  ;; This package is for internal consumption: it allows us to quickly build
-  ;; the 'guix-register' program, which is referred to by (guix config).
-  ;; TODO: Remove this hack when 'guix-register' has been superseded by Scheme
-  ;; code.
-  (package
-    (inherit guix)
-    (properties `((hidden? . #t)))
-    (name "guix-register")
-
-    ;; Use a minimum set of dependencies.
-    (native-inputs
-     (fold alist-delete (package-native-inputs guix)
-           '("po4a" "graphviz" "help2man")))
-    (propagated-inputs
-     `(("gnutls" ,gnutls)
-       ("guile-git" ,guile-git)))
-
-    (arguments
-     (substitute-keyword-arguments (package-arguments guix)
-       ((#:tests? #f #f)
-        #f)
-       ((#:phases phases '%standard-phases)
-        `(modify-phases ,phases
-           (replace 'build
-             (lambda _
-               (invoke "make" "nix/libstore/schema.sql.hh")
-               (invoke "make" "-j" (number->string
-                                    (parallel-job-count))
-                       "guix-register")))
-           (delete 'copy-bootstrap-guile)
-           (replace 'install
-             (lambda _
-               (invoke "make" "install-sbinPROGRAMS")))
-           (delete 'wrap-program)))))))
-
 (define-public guile2.0-guix
   (package
     (inherit guix)