summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-02-04 20:52:37 +0000
committerLudovic Courtès <ludo@gnu.org>2022-02-10 23:18:54 +0100
commited26d2ec6ce18851b49d17cf77dc71c79e760ed4 (patch)
tree295e0e3b82596087741c5bf3f9383b54fdb59612 /gnu
parent11b586db59537e59cca7c6c2a416c2ab7c7ac3a5 (diff)
downloadguix-ed26d2ec6ce18851b49d17cf77dc71c79e760ed4.tar.gz
gnu: lldb: Update to 13.0.1.
* gnu/packages/llvm.scm (lldb): Update to 13.0.1.
[inputs]: Change from LLVM-12 and CLANG-12 to LLVM-13 and CLANG-13.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/llvm.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index acd56c3d92..0b7800734c 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -22,6 +22,7 @@
 ;;; Copyright © 2021 Lars-Dominik Braun <lars@6xq.net>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1202,21 +1203,21 @@ misuse of libraries outside of the store.")
 (define-public lldb
   (package
     (name "lldb")
-    (version "12.0.1")
+    (version "13.0.1")
     (source (origin
               (method url-fetch)
               (uri (llvm-uri "lldb" version))
               (sha256
                (base32
-                "0g3pj1m3chafavpr35r9fynm85y2hdyla6klj0h28khxs2613i78"))))
+                "05nvcbgb4rx860r3jzsbpvcbzpd0i7nsm5qrpkyfhg5vrh5mj32a"))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags '("-DCMAKE_CXX_COMPILER=clang++")))
     (native-inputs
      (list pkg-config swig))
     (inputs
-     (list clang-12
-           llvm-12
+     (list clang-13
+           llvm-13
            ;; Optional (but recommended) inputs.
            ncurses
            libedit