summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-01-21 00:34:37 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-01-21 12:44:42 +0100
commitf07e53fb53ca2701d5051e05a7ecc95f405ec817 (patch)
treee3cff504528aa839aaac3dc2addb42897672f818 /gnu
parentc0dee46c85c9ae9f9b40f83f693f666fdd3e5d28 (diff)
downloadguix-f07e53fb53ca2701d5051e05a7ecc95f405ec817.tar.gz
gnu: gflags: Update to 2.2.0.
* gnu/packages/popt.scm (gflags): Update to 2.2.0.
[source]: Use tarball release.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/popt.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/popt.scm b/gnu/packages/popt.scm
index 3200873d58..a9b5f501da 100644
--- a/gnu/packages/popt.scm
+++ b/gnu/packages/popt.scm
@@ -20,7 +20,6 @@
 (define-module (gnu packages popt)
   #:use-module (guix packages)
   #:use-module (guix download)
-  #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system cmake)
   #:use-module (guix licenses))
@@ -95,16 +94,15 @@ similar to getopt(3), it contains a number of enhancements, including:
 (define-public gflags
   (package
     (name "gflags")
-    (version "2.1.2")
+    (version "2.2.0")
     (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (commit (string-append "v" version))
-                    (url "https://github.com/gflags/gflags.git")))
+              (method url-fetch)
+              (uri (string-append "https://github.com/gflags/gflags"
+                                  "/archive/v" version ".tar.gz"))
               (sha256
                (base32
-                "0qxvr9cyxq3px60jglkm94pq5bil8dkjjdb99l3ypqcds7iypx9w"))
-              (file-name (string-append name "-" version "-checkout"))))
+                "120z4w40zr4s8wvfyw1bdmqvincwrwjnimzlwhs1ficaa333cv26"))
+              (file-name (string-append name "-" version ".tar.gz"))))
     (build-system cmake-build-system)
     (arguments
      '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON"