summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-01-31 09:22:04 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-02-09 09:14:12 +0100
commitf47cba0efb0adeffb7fe679683a6a010f100c4a6 (patch)
tree353d04820d371ac02918b4da930c4224e260f73e /gnu
parentc54a89811f3290f2489d67867ab6f68cf3059e4e (diff)
downloadguix-f47cba0efb0adeffb7fe679683a6a010f100c4a6.tar.gz
gnu: Add liblo.
* gnu/packages/audio.scm (liblo): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index d5b862f515..e8bcd82508 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -92,3 +92,28 @@ synchronous execution of all clients, and low latency operation.")
      `(("pkg-config" ,pkg-config)))
     ;; Most files are under GPLv2+, but some headers are under LGPLv2.1+
     (license (list license:gpl2+ license:lgpl2.1+))))
+
+(define-public liblo
+  (package
+    (name "liblo")
+    (version "0.28")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "mirror://sourceforge/liblo/liblo-"
+                   version
+                   ".tar.gz"))
+             (sha256
+              (base32
+               "02drgnpirvl2ihvzgsmn02agr5sj3vipzzw9vma56qlkgfvak56s"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(;; liblo test FAILED
+       ;; liblo server error 19 in setsockopt(IP_ADD_MEMBERSHIP): No such device
+       #:tests? #f))
+    (home-page "http://liblo.sourceforge.net")
+    (synopsis "Implementation of the Open Sound Control protocol")
+    (description
+     "liblo is a lightweight library that provides an easy to use
+implementation of the Open Sound Control (OSC) protocol.")
+    (license license:lgpl2.1+)))