summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-24 14:53:51 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-24 14:53:51 +0200
commitf6ad09ae5af9f4781c5ecea2c598f4d4c26b29b6 (patch)
treea7eddfeb85d0d189cf9bde6e8a17c8bd08579252 /gnu
parent9ab7415329a8ec661c926ae6174ef1bddfb2c91c (diff)
downloadguix-f6ad09ae5af9f4781c5ecea2c598f4d4c26b29b6.tar.gz
gnu: Move JSON-C to (gnu packages web).
* gnu/packages/pulseaudio.scm (json-c): Move to...
* gnu/packages/web.scm (json-c): ... here.  New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/pulseaudio.scm36
-rw-r--r--gnu/packages/web.scm34
2 files changed, 35 insertions, 35 deletions
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index d1bf981e0a..e37f7c07e3 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -32,13 +32,13 @@
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages libcanberra)
+  #:use-module (gnu packages web)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages m4)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages xiph)
   #:export (libsndfile
             libsamplerate
-            json-c
             pulseaudio))
 
 (define libsndfile
@@ -110,40 +110,6 @@ the theoretical best bandwidth for a given pair of input and output sample
 rates. ")
     (license l:gpl2+)))
 
-(define json-c
-  (package
-    (name "json-c")
-    (version "0.12")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append "https://s3.amazonaws.com/json-c_releases/releases/json-c-"
-                                 version ".tar.gz"))
-             (sha256
-              (base32
-               "0gwzic3ifg2d0w32ya3agpxh8i083cgvf7kmc51cnbgqnfr02300"))
-             (modules '((guix build utils)))
-             (snippet
-              '(begin
-                 ;; Somehow 'config.h.in' is older than
-                 ;; 'aclocal.m4', which would trigger a rule to
-                 ;; run 'autoheader'.
-                 (set-file-time "config.h.in"
-                                (stat "aclocal.m4"))
-
-                 ;; Don't try to build with -Werror.
-                 (substitute* (find-files "." "Makefile\\.in")
-                   (("-Werror") ""))))))
-    (build-system gnu-build-system)
-    (arguments '(#:parallel-build? #f
-                 #:parallel-tests? #f))
-    (home-page "https://github.com/json-c/json-c/wiki")
-    (synopsis "JSON implementation in C")
-    (description
-     "JSON-C implements a reference counting object model that allows you to
-easily construct JSON objects in C, output them as JSON formatted strings and
-parse JSON formatted strings back into the C representation of JSON objects.")
-    (license l:x11)))
-
 (define pulseaudio
   (package
     (name "pulseaudio")
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 8b48994592..6e94953bfe 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -73,6 +73,40 @@ related documentation.")
     (license l:asl2.0)
     (home-page "https://httpd.apache.org/")))
 
+(define-public json-c
+  (package
+    (name "json-c")
+    (version "0.12")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "https://s3.amazonaws.com/json-c_releases/releases/json-c-"
+                                 version ".tar.gz"))
+             (sha256
+              (base32
+               "0gwzic3ifg2d0w32ya3agpxh8i083cgvf7kmc51cnbgqnfr02300"))
+             (modules '((guix build utils)))
+             (snippet
+              '(begin
+                 ;; Somehow 'config.h.in' is older than
+                 ;; 'aclocal.m4', which would trigger a rule to
+                 ;; run 'autoheader'.
+                 (set-file-time "config.h.in"
+                                (stat "aclocal.m4"))
+
+                 ;; Don't try to build with -Werror.
+                 (substitute* (find-files "." "Makefile\\.in")
+                   (("-Werror") ""))))))
+    (build-system gnu-build-system)
+    (arguments '(#:parallel-build? #f
+                 #:parallel-tests? #f))
+    (home-page "https://github.com/json-c/json-c/wiki")
+    (synopsis "JSON implementation in C")
+    (description
+     "JSON-C implements a reference counting object model that allows you to
+easily construct JSON objects in C, output them as JSON formatted strings and
+parse JSON formatted strings back into the C representation of JSON objects.")
+    (license l:x11)))
+
 (define-public libwebsockets
   (package
     (name "libwebsockets")