summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-31 11:12:41 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-31 12:54:47 +0300
commitf7f1efeaa78d157562eda3cfb1d1cd1e2d98153a (patch)
tree1e16c26041abcd79041f170abb45d16ef23dc6c6 /gnu
parent2bd2406cd902a9ef4715269e12ddb551f9255b41 (diff)
downloadguix-f7f1efeaa78d157562eda3cfb1d1cd1e2d98153a.tar.gz
gnu: Add julia-statsapi.
* gnu/packages/julia-xyz.scm (julia-statsapi): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index cfa6b5ef43..9d43ffb8af 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1721,6 +1721,29 @@ statically sized arrays in Julia, using the abstract type
 linear algebra operations.")
     (license license:expat)))
 
+(define-public julia-statsapi
+  (package
+    (name "julia-statsapi")
+    (version "1.0.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaStats/StatsAPI.jl")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "1k1c3s7i5wzkz4r9fyy4gd7wb97p0qgbc7bmaajm16zqipfmy2bv"))))
+    (build-system julia-build-system)
+    (home-page "https://juliastats.org/")
+    (synopsis "Statistics-focused namespace for packages to share functions")
+    (description "This package provides a namespace for data-related generic
+function definitions to solve the optional dependency problem; packages wishing
+to share and/or extend functions can avoid depending directly on each other by
+moving the function definition to @code{StatsAPI.jl} and each package taking a
+dependency on it.")
+    (license license:expat)))
+
 (define-public julia-suppressor
   (package
     (name "julia-suppressor")