summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-11 20:47:14 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-07-20 10:11:35 +0200
commitfb6f94864d1c1b3a6c46f3b880b8a51003854f89 (patch)
tree858bbc62604ededb9377e320e8a60b68642a672e /gnu
parent69142dbea4eb5148ed165b494cae0ad730bf5514 (diff)
downloadguix-fb6f94864d1c1b3a6c46f3b880b8a51003854f89.tar.gz
gnu: openssl-1.1: Fix shared build for the Hurd.
* gnu/packages/tls.scm (openssl-1.1)[arguments]: When building for the Hurd,
add phase 'patch-configure'.
(openssl)[arguments]: And delete it again.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tls.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index a2ed15ebdc..f51c47db04 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -470,6 +470,13 @@ OpenSSL for TARGET."
                                 #$(target->openssl-target
                                    (%current-target-system))))))
                  #~())
+          #$@(if (target-hurd?)
+                 #~((add-after 'unpack 'patch-configure
+                      (lambda _
+                        (substitute* "config"
+                          (("case \"\\$GUESSOS\" in.*" all)
+                           (string-append all "hurd-x86*) OUT=hurd-x86;;\n"))))))
+                 #~())
           (replace 'configure
             (lambda* (#:key configure-flags #:allow-other-keys)
               ;; It's not a shebang so patch-source-shebangs misses it.
@@ -585,7 +592,10 @@ OpenSSL for TARGET."
               (lambda* (#:key native-inputs inputs #:allow-other-keys)
                 (setenv "HASHBANGPERL"
                         (search-input-file (or native-inputs inputs)
-                                           "/bin/perl"))))))
+                                           "/bin/perl"))))
+            #$@(if (target-hurd?)
+                   #~((delete 'patch-configure))
+                   #~())))
        ((#:configure-flags flags #~'())
         (if (system-hurd?)
             #~(append #$flags '("hurd-x86")) ;must not be used when