summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-05 18:21:28 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commitfe34f0d152e41d49d63385f12ae7b84774bf3196 (patch)
treea4d8ee5d0ee45ec4e8a90656fcf56738fa563262 /gnu
parent8176d4d55bb05972101373076c5ff7e4085e1c95 (diff)
downloadguix-fe34f0d152e41d49d63385f12ae7b84774bf3196.tar.gz
gnu: Add python-jinja2.
* gnu/packages/python.scm (python-jinja2, python2-jinja2): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ab6e5ac275..41cab408c2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1722,3 +1722,30 @@ for Python.")
 
 (define-public python2-markupsafe
   (package-with-python2 python-markupsafe))
+
+(define-public python-jinja2
+  (package
+    (name "python-jinja2")
+    (version "2.7.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/J/Jinja2/Jinja2-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "1nwg9yfqgy421lncnm63k1zf9xkd1klc0jm0fr4p3dad01fsq91f"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-setuptools" ,python-setuptools)
+       ("python-markupsafe" ,python-markupsafe)))
+    (home-page "http://jinja.pocoo.org/")
+    (synopsis "Python template engine")
+    (description
+     "Jinja2 is a small but fast and easy to use stand-alone template engine
+written in pure Python.")
+    (license bsd-3)))
+
+(define-public python2-jinja2
+  (package-with-python2 python-jinja2))