summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-05-24 22:51:54 +0100
committerVinicius Monego <monego@posteo.net>2023-05-25 21:20:06 -0300
commit3299b40b3599371890816b52d65a6a5ada1b1131 (patch)
treeceffe2d5ea3fcd48717cafe76900ba341b6e8faf /gnu
parentb9bf533f15487956e73f7e4c3573bbfed68e2192 (diff)
downloadguix-3299b40b3599371890816b52d65a6a5ada1b1131.tar.gz
gnu: python-asdf: Enable tests.
* gnu/packages/astronomy.scm (python-asdf)[arguments]: Remove #:tests, skip
failing tests in #:test-flags.

Signed-off-by: Vinicius Monego <monego@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index eeaa51f53a..964e72642c 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2735,12 +2735,12 @@ datetime object.")
         (base32 "11s56797l5330kkhppkyz0bsvms016knmyswj4gx91zrxf8iqvv8"))))
     (build-system pyproject-build-system)
     (arguments
-     ;; FIXME: Tests fail a lot with
-     ;;
-     ;; ERROR  - _pytest.pathlib.ImportPathMismatchError:
-     ;; ('asdf.conftest', '/gnu/sto...
-     ;;
-     `(#:tests? #f))
+     (list #:test-flags
+           #~(list "-k" (string-append
+                         "not test_overwrite"
+                         " and not test_tagging_scalars"
+                         " and not test_info_command"
+                         " and not test_array_inline_threshold_recursive"))))
     (native-inputs
      (list python-astropy
            python-fsspec