summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2017-07-27 17:11:08 +0200
committerJelle Licht <jlicht@fsfe.org>2017-09-02 22:59:18 +0200
commit448339709d85b77e89651a2f4facf57e31c79b4a (patch)
tree8565df78773c4c5ea3dabb93bd9d44af2338a270 /gnu
parent4da9beab14a21040afd8c0deb8c4f5a3576b6933 (diff)
downloadguix-448339709d85b77e89651a2f4facf57e31c79b4a.tar.gz
gnu: node: Update to 8.4.0.
* gnu/packages/patches/node-9077.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/node.scm (node): Update to 8.4.0.
(node)[arguments]: Removed broken linter test. Removed dns test.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/node.scm12
-rw-r--r--gnu/packages/patches/node-9077.patch31
3 files changed, 5 insertions, 39 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 05a640428d..643a88db81 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -872,7 +872,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/newsbeuter-CVE-2017-12904.patch		\
   %D%/packages/patches/ngircd-handle-zombies.patch		\
   %D%/packages/patches/ninja-zero-mtime.patch			\
-  %D%/packages/patches/node-9077.patch				\
   %D%/packages/patches/nss-increase-test-timeout.patch		\
   %D%/packages/patches/nss-pkgconfig.patch			\
   %D%/packages/patches/nvi-assume-preserve-path.patch		\
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 2cebabbcaf..805b81bd2e 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -40,16 +40,14 @@
 (define-public node
   (package
     (name "node")
-    (version "8.1.2")
+    (version "8.4.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://nodejs.org/dist/v" version
                                   "/node-v" version ".tar.gz"))
               (sha256
                (base32
-                "0l92gar1pivzaiwffiiiz2f2m5k39sl5fphlfnvy0ml9hrjb65yp"))
-              ;; https://github.com/nodejs/node/pull/9077
-              (patches (search-patches "node-9077.patch"))))
+                "1vrpc4lspm33hmb8c2q4w1fzg3iaip2gx4wpr4nyy417hbx1a6k4"))))
     (build-system gnu-build-system)
     (arguments
      ;; TODO: Purge the bundled copies from the source.
@@ -78,10 +76,9 @@
                (("'/usr/bin/env'")
                 (string-append "'" (which "env") "'")))
 
-             ;; Having the build fail because of linter errors is insane!
+             ;; Linting is no longer supported in the release tarball
              (substitute* '("Makefile")
-               (("	\\$\\(MAKE\\) jslint") "")
-               (("	\\$\\(MAKE\\) cpplint\n") ""))
+               (("	\\$\\(MAKE\\) lint") ""))
 
              ;; FIXME: This test seems to depends on files that are not
              ;; available in the bundled v8. See
@@ -95,6 +92,7 @@
                          "test/parallel/test-util-inspect.js"
                          "test/parallel/test-v8-serdes.js"
                          "test/parallel/test-dgram-membership.js"
+                         "test/parallel/test-dns-resolveany.js"
                          "test/parallel/test-cluster-master-error.js"
                          "test/parallel/test-cluster-master-kill.js"
                          "test/parallel/test-npm-install.js"
diff --git a/gnu/packages/patches/node-9077.patch b/gnu/packages/patches/node-9077.patch
deleted file mode 100644
index 6b71d48c0e..0000000000
--- a/gnu/packages/patches/node-9077.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From fc164acbbb700fd50ab9c04b47fc1b2687e9c0f4 Mon Sep 17 00:00:00 2001
-From: "Bradley T. Hughes" <bradleythughes@fastmail.fm>
-Date: Thu, 13 Oct 2016 07:38:38 +0000
-Subject: [PATCH] build: add -DZLIB_CONST when building with --shared-zlib
-
-Commit 782620f added the define only when building with the bundled
-zlib. Using a shared zlib results in build breakage:
-
-../src/inspector_agent.cc:179:16: error: assigning to 'Bytef *' (aka 'unsigned char *') from incompatible type
-      'const uint8_t *' (aka 'const unsigned char *')
-  strm.next_in = PROTOCOL_JSON + 3;
-               ^ ~~~~~~~~~~~~~~~~~
-1 error generated.
----
- node.gyp | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/node.gyp b/node.gyp
-index 272dc98..667c260 100644
---- a/node.gyp
-+++ b/node.gyp
-@@ -653,7 +653,8 @@
-             [ 'node_shared_zlib=="false"', {
-               'dependencies': [
-                 'deps/zlib/zlib.gyp:zlib',
--              ]
-+              ]}, {
-+              'defines': [ 'ZLIB_CONST' ],
-             }],
-             [ 'node_shared_openssl=="false"', {
-               'dependencies': [