summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-02-05 14:35:39 +0100
committerLudovic Courtès <ludo@gnu.org>2020-02-05 16:18:58 +0100
commit895363e4cfa63cba1cc36515d69e7e0ce14886a9 (patch)
treeb0e473c76f11e02115c197fdafd104980a467f16 /gnu
parent8534c9491d86406ade201bacc3b14fdf63a1f39d (diff)
downloadguix-895363e4cfa63cba1cc36515d69e7e0ce14886a9.tar.gz
gnu: cat-avatar-generator: Remove imports for (srfi *).
This would import (srfi srfi-1) and (srfi srfi-26) from the host Guile,
leading to discrepancies among users, and in particular when the host
Guile is 3.0.

Reported by Julien Lepiller <julien@lepiller.eu>
in <https://bugs.gnu.org/39369>.

* gnu/packages/web.scm (cat-avatar-generator): Remove (srfi *) from
 #:modules.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3d73bfec2b..f38f8d2bfb 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2013 Aljosha Papsch <misc@rpapsch.de>
-;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018 Raoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>
@@ -6806,14 +6806,13 @@ features include:
                 "0s7b5whqsmfa57prbgl66ym551kg6ly0z14h5dgrlx4lqm70y2yw"))))
     (build-system trivial-build-system)
     (arguments
-     `(#:modules ((guix build utils)
-                  (srfi srfi-1)
-                  (srfi srfi-26))
+     `(#:modules ((guix build utils))
        #:builder
        (begin
          (use-modules (guix build utils)
                       (srfi srfi-1)
                       (srfi srfi-26))
+
          (let ((source (assoc-ref %build-inputs "source"))
                (php-dir (string-append %output "/share/web/" ,name "/")))
            ;; The cache directory must not be in the store, but in a writable