summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-29 21:02:15 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-03-29 21:02:15 +0300
commit04950d1ff6816d69723bbb176483dfbe230dcf41 (patch)
tree0019da7f1f4a5c5e286596890776b89b2accbef4 /gnu
parent4eb40497b69909922a50d3dafdd90a0fbc7084b4 (diff)
downloadguix-04950d1ff6816d69723bbb176483dfbe230dcf41.tar.gz
gnu: tesseract-ocr: Don't use unstable tarball.
* gnu/packages/ocr.scm (tesseract-ocr)[source]: Download using git-fetch.
[home-page]: Use full URL.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocr.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/ocr.scm b/gnu/packages/ocr.scm
index 1266e7e419..dc690f3cef 100644
--- a/gnu/packages/ocr.scm
+++ b/gnu/packages/ocr.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
 ;;;
@@ -57,13 +57,13 @@ it produces text in 8-bit or UTF-8 formats.")
     (version "3.04.01")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/tesseract-ocr/tesseract/archive/"
-             version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/tesseract-ocr/tesseract")
+              (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "0snwd8as5i8vx7zkimpd2yg898jl96zf90r65a9w615f2hdkxxjp"))))
+        (base32 "0h1x4z1h86n2gwknd0wck6gykkp99bmm02lg4a47a698g4az6ybv"))))
     (build-system gnu-build-system)
     (inputs
      `(("leptonica" ,leptonica)))
@@ -71,7 +71,7 @@ it produces text in 8-bit or UTF-8 formats.")
      '(#:configure-flags
        (let ((leptonica (assoc-ref %build-inputs "leptonica")))
          (list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))))
-    (home-page "https://github.com/tesseract-ocr")
+    (home-page "https://github.com/tesseract-ocr/tesseract")
     (synopsis "Optical character recognition engine")
     (description
      "Tesseract is an optical character recognition (OCR) engine with very