summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-16 16:20:11 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-10-16 16:49:08 +0200
commit08f535eb2d438e52c1e84cefc1c270b9ad50620d (patch)
tree02d08f714fe49ef034efcf81e8f813bd6aa5c746 /gnu
parent1a2d8d06b53c3c8cf8f94920c6e8734c71b8369b (diff)
downloadguix-08f535eb2d438e52c1e84cefc1c270b9ad50620d.tar.gz
gnu: chez: Adjust to zlib static output.
* gnu/packages/chez.scm (chez-scheme)[inputs]: Add ZLIB:STATIC.
[arguments]: Reference libz.a from that instead of ZLIB.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/chez.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index c8e76b8ab4..929e50ee9b 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -85,6 +85,7 @@
        ("xorg-rgb" ,xorg-rgb)
        ("nanopass" ,nanopass)
        ("zlib" ,zlib)
+       ("zlib:static" ,zlib "static")
        ("stex" ,stex)))
     (native-inputs
      `(("texlive" ,texlive)
@@ -128,6 +129,7 @@
                    (nanopass (assoc-ref inputs "nanopass"))
                    (stex (assoc-ref inputs "stex"))
                    (zlib (assoc-ref inputs "zlib"))
+                   (zlib-static (assoc-ref inputs "zlib:static"))
                    (unpack (assoc-ref %standard-phases 'unpack))
                    (patch-source-shebangs
                     (assoc-ref %standard-phases 'patch-source-shebangs)))
@@ -148,7 +150,7 @@
                  (("\\$\\{Kernel\\}: \\$\\{kernelobj\\} \\.\\./zlib/libz\\.a")
                   "${Kernel}: ${kernelobj}")
                  (("ld ([-a-zA-Z0-9_${} ]+) \\.\\./zlib/libz\\.a" all args)
-                  (string-append "ld " args " " zlib "/lib/libz.a"))
+                  (string-append "ld " args " " zlib-static "/lib/libz.a"))
                  (("\\(cd \\.\\./zlib; ([-a-zA-Z0-9=./ ]+))")
                   (which "true")))
                (substitute* (find-files "mats" "Mf-.*")