summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-11-01 13:20:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-04 11:21:37 +0100
commit4263b06fa2bf3e25ec21fa39822b548fc3a6e8ca (patch)
treeb1dbd4247f0798860fcfe77c7ee85fddacef1e7b /gnu
parenta5ba14811ab7657ac895235b91b0f64f959ee2d8 (diff)
downloadguix-4263b06fa2bf3e25ec21fa39822b548fc3a6e8ca.tar.gz
gnu: Add python-jupyter-core.
* gnu/packages/python.scm (python-jupyter-core, python2-jupyter-core):
New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c612846349..da16647c2d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4500,6 +4500,31 @@ without using the configuration machinery.")
 (define-public python2-traitlets
   (package-with-python2 python-traitlets))
 
+(define-public python-jupyter-core
+  (package
+    (name "python-jupyter-core")
+    (version "4.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append (pypi-uri "jupyter_core" version)))
+       (sha256
+        (base32
+         "177d9csqldzhsh6xs1p4nf6lzvhzyg6gklqjf69lxgxyadx87v24"))))
+    (build-system python-build-system)
+    ;; FIXME: not sure how to run the tests
+    (arguments `(#:tests? #f))
+    (propagated-inputs
+     `(("python-traitlets" ,python-traitlets)))
+    (home-page "http://jupyter.org/")
+    (synopsis "Jupyter base package")
+    (description
+     "Jupyter core is the base package on which Jupyter projects rely.")
+    (license license:bsd-3)))
+
+(define-public python2-jupyter-core
+  (package-with-python2 python-jupyter-core))
+
 (define-public python-ipython
   (package
     (name "python-ipython")