summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-11-01 13:20:43 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-04 21:23:06 +0100
commit4fe2e34409cb1aad6a19e2cf93ebeb7f555a703f (patch)
treed4882572e197627c3f6f02d93214994ca52f880e /gnu
parentd55724ed5b07b218131dcffcdf694ce98a87da5e (diff)
downloadguix-4fe2e34409cb1aad6a19e2cf93ebeb7f555a703f.tar.gz
gnu: Add python-ipywidgets.
* gnu/packages/python.scm (python-ipywidgets, python2-ipywidgets): New
variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8145938d05..3f0b2b3dd5 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6868,6 +6868,37 @@ notebooks.")
 (define-public python2-widgetsnbextension
   (package-with-python2 python-widgetsnbextension))
 
+(define-public python-ipywidgets
+  (package
+    (name "python-ipywidgets")
+    (version "5.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ipywidgets" version))
+       (sha256
+        (base32
+         "1lk0qrr5l9a0z7qkkn30hv5832whxwxymf1l576fmmad0n7hkxms"))))
+    (build-system python-build-system)
+    ;; FIXME: it's not clear how to run the tests.
+    (arguments `(#:tests? #f))
+    (propagated-inputs
+     `(("python-ipykernel" ,python-ipykernel)
+       ("python-ipython" ,python-ipython)
+       ("python-setuptools" ,python-setuptools)
+       ("python-traitlets" ,python-traitlets)
+       ("python-widgetsnbextension" ,python-widgetsnbextension)))
+    (home-page "http://ipython.org")
+    (synopsis "IPython HTML widgets for Jupyter")
+    (description "Ipywidgets are interactive HTML widgets for Jupyter
+notebooks and the IPython kernel.  Notebooks come alive when interactive
+widgets are used.  Users gain control of their data and can visualize changes
+in the data.")
+    (license license:bsd-3)))
+
+(define-public python2-ipywidgets
+  (package-with-python2 python-ipywidgets))
+
 (define-public python-chardet
   (package
     (name "python-chardet")