summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2015-07-08 19:32:20 +0300
committerAlex Kost <alezost@gmail.com>2015-07-14 18:46:17 +0300
commit60a5617b9dbced3a3b3dfc950cf52f2117d0b687 (patch)
treea9c3da536e239469cfae4e71901d2aeca6cec2ef /gnu
parent661a1d7924e174a28e0e21bf516aa1a8a44dad73 (diff)
downloadguix-60a5617b9dbced3a3b3dfc950cf52f2117d0b687.tar.gz
gnu: Add libxdg-basedir.
* gnu/packages/freedesktop.scm (libxdg-basedir): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/freedesktop.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index eeb97cdc85..5cdb4568c5 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -91,6 +91,39 @@ freedesktop.org project.")
 other applications that need to directly deal with input devices.")
     (license license:x11)))
 
+(define-public libxdg-basedir
+  (package
+    (name "libxdg-basedir")
+    (version "1.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/devnev/libxdg-basedir/archive/"
+                    name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0s28c7sfwqimsmb3kn91mx7wi55fs3flhbmynl9k60rrllr00aqw"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'autogen
+           (lambda _
+             ;; Run 'configure' in its own phase, not now.
+             (substitute* "autogen.sh"
+               (("^.*\\./configure.*") ""))
+             (zero? (system* "sh" "autogen.sh")))))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)))
+    (home-page "https://github.com/devnev/libxdg-basedir")
+    (synopsis "Implementation of the XDG Base Directory specification")
+    (description
+     "libxdg-basedir is a C library providing some functions to use with
+the freedesktop.org XDG Base Directory specification.")
+    (license license:expat)))
+
 (define-public elogind
   (let ((commit "14405a9"))
     (package