summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-07-14 14:00:46 +0200
committerLudovic Courtès <ludo@gnu.org>2015-07-14 14:00:46 +0200
commit7e5124976b0bc19cf26ef7376ea041b25b7fbd35 (patch)
tree9405b81570f64517636291d16b8630a07a162176 /gnu
parent1b9cf4ad2fa4149e436787fcf50e4f68a098f32a (diff)
downloadguix-7e5124976b0bc19cf26ef7376ea041b25b7fbd35.tar.gz
gnu: util-linux: Fix file name of 'umount' in 'eject'.
Fixes <http://bugs.gnu.org/21010>.
Reported by Alex Sassmannshausen <alex.sassmannshausen@gmail.com>.

* gnu/packages/linux.scm (util-linux)[arguments]: Add 'set-umount-file-name'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f27b8281ab..c5d055366e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -419,6 +419,15 @@ providing the system administrator with some help in common tasks.")
                                               "/etc/bash_completion.d"))
        #:phases (modify-phases %standard-phases
                   (add-before
+                   'build 'set-umount-file-name
+                   (lambda* (#:key outputs #:allow-other-keys)
+                     ;; Tell 'eject' the right file name of 'umount'.
+                     (let ((out (assoc-ref outputs "out")))
+                       (substitute* "sys-utils/eject.c"
+                         (("\"/bin/umount\"")
+                          (string-append "\"" out "/bin/umount\"")))
+                       #t)))
+                  (add-before
                    'check 'pre-check
                    (lambda* (#:key inputs outputs #:allow-other-keys)
                      (let ((out (assoc-ref outputs "out"))