summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorrain1 <rain1@openmailbox.org>2016-03-30 13:05:19 +0100
committerMark H Weaver <mhw@netris.org>2016-03-30 15:22:04 -0400
commit96e9f097ee1899cf9e41ce2756a684b0a2dc52f3 (patch)
tree1fd1a13fa9bc971f734b1aef5895c0a34e0e73c6 /gnu
parentaa2a0d4bb8e60321a814860f08eebfcf78dfde8f (diff)
downloadguix-96e9f097ee1899cf9e41ce2756a684b0a2dc52f3.tar.gz
gnu: linux-libre: Avoid introducing timestamps into the build.
* gnu/packages/linux.scm (linux-libre)[build-phase]: Set the
KCONFIG_NOTIMESTAMP and KBUILD_BUILD_TIMESTAMP environment variables to
avoid introducing timestamps into the build outputs.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index fb2b671bb9..3a4c9f114d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9,6 +9,7 @@
 ;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
 ;;; Copyright © 2016 Tobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>
 ;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
+;;; Copyright © 2016 Raymond Nicholson <rain1@openmailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -223,6 +224,10 @@ for SYSTEM and optionally VARIANT, or #f if there is no such configuration."
   (let* ((version "4.5")
          (build-phase
           '(lambda* (#:key system inputs #:allow-other-keys #:rest args)
+             ;; Avoid introducing timestamps
+             (setenv "KCONFIG_NOTIMESTAMP" "1")
+             (setenv "KBUILD_BUILD_TIMESTAMP" (getenv "SOURCE_DATE_EPOCH"))
+
              ;; Apply the neat patch.
              (system* "patch" "-p1" "--force"
                       "-i" (assoc-ref inputs "patch/freedo+gnu"))