summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-04-11 03:18:26 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-04-11 04:14:28 +0200
commit9a71213e3344383bc937ccfdd4efe965b5935821 (patch)
tree638154300df711f7bb91b45e0c0785a3211dd26a /gnu
parentfd13a65cda0fb50877d7bbe10acbf05f5a16cce6 (diff)
downloadguix-9a71213e3344383bc937ccfdd4efe965b5935821.tar.gz
gnu: dbacl: Update to 1.14.1.
* gnu/packages/textutils.scm (dbacl): Update to 1.14.1.
[source]: Add patch to fix build with current glibc.
[arguments]: (Try to) bootstrap only once.
* gnu/packages/patches/dbacl-include-locale.h.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/dbacl-include-locale.h.patch36
-rw-r--r--gnu/packages/textutils.scm20
3 files changed, 47 insertions, 10 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 73f9d5d69c..aba58ae03a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -824,6 +824,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/cvs-CVE-2017-12836.patch		\
   %D%/packages/patches/date-output-pkg-config-files.patch	\
   %D%/packages/patches/darkice-workaround-fpermissive-error.patch	\
+  %D%/packages/patches/dbacl-include-locale.h.patch		\
   %D%/packages/patches/dbus-helper-search-path.patch		\
   %D%/packages/patches/dbus-c++-gcc-compat.patch		\
   %D%/packages/patches/dbus-c++-threading-mutex.patch		\
diff --git a/gnu/packages/patches/dbacl-include-locale.h.patch b/gnu/packages/patches/dbacl-include-locale.h.patch
new file mode 100644
index 0000000000..40d5d0aa44
--- /dev/null
+++ b/gnu/packages/patches/dbacl-include-locale.h.patch
@@ -0,0 +1,36 @@
+From: Tobias Geerinckx-Rice <me@tobias.gr>
+Date: Sat, 11 Apr 2020 03:02:04 +0200
+Subject: [PATCH] gnu: dbacl: Include <locale.h> in dbacl.h.
+
+Copied verbatim[0] from Debian.
+
+[0]: https://sources.debian.org/data/main/d/dbacl/1.14.1-2/debian/patches/05-locale-h.patch
+
+Description: Add missing <locale.h> include in dbacl.h
+Author: Fabian Wolff <fabi.wolff@arcor.de>
+Bug-Debian: https://bugs.debian.org/916182
+Last-Update: 2019-08-25
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/src/dbacl.h
++++ b/src/dbacl.h
+@@ -21,6 +21,8 @@
+ #ifndef DBACL_H
+ #define DBACL_H
+ 
++#include <locale.h>
++
+ #ifdef HAVE_CONFIG_H
+ #undef HAVE_CONFIG_H
+ #include "config.h"
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -28,7 +28,7 @@
+ # stuff_SOURCES = stuff.c stuff.h fram.c stuff-lexer.l stuff-parser.y stuff-parser.h probs.c util.c util.h $(PUBDOM)
+ # stuff_LDADD = @LEXLIB@
+ 
+-AM_CFLAGS = -funsigned-char -std=c99 -Wall -pedantic $(CFLAGSIEEE) -O3
++AM_CFLAGS = -funsigned-char -std=c99 -D_XOPEN_SOURCE=700 -Wall -pedantic $(CFLAGSIEEE) -O3
+ AM_YFLAGS = -d
+ 
+ CLEANFILES = mailcross mailtoe mailfoot 
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 8510c6d1d0..62988ec574 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -13,7 +13,7 @@
 ;;; Copyright © 2017,2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
 ;;; Copyright © 2019 Yoshinori Arai <kumagusu08@gmail.com>
@@ -612,15 +612,15 @@ in a portable way.")
 (define-public dbacl
   (package
     (name "dbacl")
-    (version "1.14")
+    (version "1.14.1")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "http://www.lbreyer.com/gpl/"
+       (uri (string-append "mirror://sourceforge/dbacl/dbacl/" version "/"
                            "dbacl-" version ".tar.gz"))
        (sha256
-        (base32
-         "0224g6x71hyvy7jikfxmgcwww1r5lvk0jx36cva319cb9nmrbrq7"))))
+        (base32 "1gas0112wqjvwn9qg3hxnawk7h3prr0w9b2h68f3p1ifd1kzn3gz"))
+       (patches (search-patches "dbacl-include-locale.h.patch"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags
@@ -648,10 +648,6 @@ in a portable way.")
            (lambda _
              (delete-file "src/tests/dbacl-jap.shin")
              #t))
-         (add-after 'delete-sample6-and-japanese 'autoreconf
-           (lambda _
-             (invoke "autoreconf" "-vif")
-             #t))
          (add-after 'unpack 'fix-test-files
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
@@ -661,7 +657,11 @@ in a portable way.")
                   "#PATH=/bin:/usr/bin")
                  (("diff") (string-append (which "diff")))
                  (("tr") (string-append (which "tr"))))
-               #t))))))
+               #t)))
+         (replace 'bootstrap
+           (lambda _
+             (invoke "autoreconf" "-vif")
+             #t)))))
     (inputs
      `(("ncurses" ,ncurses)
        ("perl" ,perl)