summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-10-17 20:17:12 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-10-17 21:12:38 +0200
commit9fbd0b17691dbe5f9ef76c5def4c1588bccd4a53 (patch)
tree17dabc242a393f2c6e71ebeb85d6a7f8d6cabbba /gnu
parentbf67988070f61b048cad15f6eb53791e048a1372 (diff)
downloadguix-9fbd0b17691dbe5f9ef76c5def4c1588bccd4a53.tar.gz
gnu: neovim: Remove unneeded reference.
gnu/packages/vim.scm (neovim)[arguments]: Add a phase to remove a
reference to the compiler.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/vim.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 9515b1765b..63bd50390c 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -775,7 +775,15 @@ are detected, the user is notified.")))
                        (string-join (map lua-path-spec lua-inputs) ";"))
                (setenv "LUA_CPATH"
                        (string-join (map lua-cpath-spec lua-inputs) ";"))
-               #t))))))
+               #t)))
+         (add-after 'unpack 'prevent-embedding-gcc-store-path
+           (lambda _
+             ;; nvim remembers its build options, including the compiler with
+             ;; its complete path.  This adds gcc to the closure of nvim, which
+             ;; doubles its size.  We remove the refirence here.
+             (substitute* "cmake/GetCompileFlags.cmake"
+               (("\\$\\{CMAKE_C_COMPILER\\}") "/gnu/store/.../bin/gcc"))
+             #t)))))
     (inputs
      `(("libuv" ,libuv)
        ("msgpack" ,msgpack)