summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-03-29 14:30:38 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-03-30 12:02:28 +0200
commita080e50c153d3f72370e140eaf589d448867bf41 (patch)
tree5e853e6dd58062834c380da56ab0a9efea9ae93a /gnu
parentf315f4fcaba7b57ef73b66f8982545c7aaac6369 (diff)
downloadguix-a080e50c153d3f72370e140eaf589d448867bf41.tar.gz
gnu: Add r-withr.
* gnu/packages/statistics.scm (r-withr): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 15c68238e2..28ac9673cc 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1260,6 +1260,25 @@ informative error messages when it's not available.")
 tools to simplify the devolpment of R packages.")
     (license license:gpl2+)))
 
+(define-public r-withr
+  (package
+    (name "r-withr")
+    (version "1.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "withr" version))
+              (sha256
+               (base32
+                "0zbj3rd7dc0ycknmay7y7rm1qvnh9n05jw93gjggz46j2zfmy93y"))))
+    (build-system r-build-system)
+    (home-page "https://github.com/jimhester/withr")
+    (synopsis "Run code with temporarily modified global state")
+    (description
+     "This package provides a set of functions to run R code in an environment
+in which global state has been temporarily modified.  Many of these functions
+were originally a part of the r-devtools package.")
+    (license license:gpl2+)))
+
 (define-public r-readr
   (package
     (name "r-readr")