summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-02 16:43:33 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-02 19:53:06 +0200
commita69f071537ce5dfd3419054dc85a598d0b702864 (patch)
tree139fd8c88bd0e1ae4bdb7bf3acd9a01e82c46246 /gnu
parent2879e605bfa59fe33e78f6a425fee70dcebaac38 (diff)
downloadguix-a69f071537ce5dfd3419054dc85a598d0b702864.tar.gz
gnu: owncloud-client: Update to 2.5.1.10973.
* gnu/packages/sync.scm (owncloud-client): Update to 2.5.1.10973.
* gnu/packages/patches/owncloud-disable-updatecheck.patch: Update patch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patches/owncloud-disable-updatecheck.patch38
-rw-r--r--gnu/packages/sync.scm6
2 files changed, 22 insertions, 22 deletions
diff --git a/gnu/packages/patches/owncloud-disable-updatecheck.patch b/gnu/packages/patches/owncloud-disable-updatecheck.patch
index 69a984a104..3469398eb4 100644
--- a/gnu/packages/patches/owncloud-disable-updatecheck.patch
+++ b/gnu/packages/patches/owncloud-disable-updatecheck.patch
@@ -10,14 +10,14 @@ Last-Update: 2014-02-17
 This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
 --- a/src/libsync/configfile.cpp
 +++ b/src/libsync/configfile.cpp
-@@ -417,11 +417,14 @@ bool ConfigFile::skipUpdateCheck( const
-     QString con( connection );
-     if( connection.isEmpty() ) con = defaultConnection();
-
+@@ -522,11 +522,14 @@ bool ConfigFile::skipUpdateCheck(const Q
+     if (connection.isEmpty())
+         con = defaultConnection();
+ 
 -    QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, false);
 +    QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, true);
      fallback = getValue(QLatin1String(skipUpdateCheckC), QString(), fallback);
-
+ 
      QVariant value = getPolicySetting(QLatin1String(skipUpdateCheckC), fallback);
 -    return value.toBool();
 +    if ( !value.toBool() )
@@ -25,25 +25,25 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
 +
 +    return true;
  }
-
- void ConfigFile::setSkipUpdateCheck( bool skip, const QString& connection )
+ 
+ void ConfigFile::setSkipUpdateCheck(bool skip, const QString &connection)
 --- a/src/gui/generalsettings.cpp
 +++ b/src/gui/generalsettings.cpp
-@@ -124,6 +124,7 @@ void GeneralSettings::loadMiscSettings()
-
+@@ -146,6 +149,7 @@ void GeneralSettings::loadMiscSettings()
+ 
  void GeneralSettings::slotUpdateInfo()
  {
 +    /* Guix doesn't want an autoupdater
-     // Note: the sparkle-updater is not an OCUpdater
-     OCUpdater *updater = qobject_cast<OCUpdater*>(Updater::instance());
-     if (ConfigFile().skipUpdateCheck()) {
-@@ -140,6 +141,9 @@ void GeneralSettings::slotUpdateInfo()
-         // can't have those infos from sparkle currently
-         _ui->updatesGroupBox->setVisible(false);
-     }
+     if (ConfigFile().skipUpdateCheck() || !Updater::instance()) {
+         // updater disabled on compile
+         _ui->updaterWidget->setVisible(false);
+@@ -174,6 +178,9 @@ void GeneralSettings::slotUpdateInfo()
+     _ui->updateChannel->setCurrentIndex(ConfigFile().updateChannel() == "beta" ? 1 : 0);
+     connect(_ui->updateChannel, static_cast<void (QComboBox::*)(int)>(&QComboBox::currentIndexChanged),
+         this, &GeneralSettings::slotUpdateChannelChanged, Qt::UniqueConnection);
 +    */
 +    //hide the update group box for Guix.
-+    _ui->updatesGroupBox->setVisible(false);
++    _ui->updaterWidget->setVisible(false);
  }
-
- void GeneralSettings::saveMiscSettings()
+ 
+ void GeneralSettings::slotUpdateChannelChanged(int index)
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 7e0da38285..596ef4b5c0 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
@@ -48,14 +48,14 @@
 (define-public owncloud-client
   (package
     (name "owncloud-client")
-    (version "2.4.1")
+    (version "2.5.1.10973")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://download.owncloud.com/desktop/stable/"
                            "owncloudclient-" version ".tar.xz"))
        (sha256
-        (base32 "08xayz0alvypwa1bjmw1rmh4m3sclld4yq7kcbf264983icawqj4"))
+        (base32 "19x4rbnqg7f7hspz1xy86b1q51q1n5y7yvq8kqc1m64n2r2s3srk"))
        (patches (search-patches "owncloud-disable-updatecheck.patch"))
        (modules '((guix build utils)))
        (snippet