summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-03-30 22:45:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-03-30 22:45:35 +0300
commitddb8312911caa3e6d6039c098f544ab4296758b7 (patch)
tree407169c1bdc104937df8038ac2887b22d6a86811 /gnu
parent96e9f097ee1899cf9e41ce2756a684b0a2dc52f3 (diff)
downloadguix-ddb8312911caa3e6d6039c098f544ab4296758b7.tar.gz
gnu: python2-pbcore: Update to 1.2.8.
* gnu/packages/bioinformatics.scm (python2-pbcore): Update to 1.2.8.
[native-inputs]: Add python2-docutils, python2-nose, python2-sphinx.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 887f6cc99b..250deb9b6b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2015, 2016 Pjotr Prins <pjotr.guix@thebird.nl>
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2507,16 +2508,13 @@ interrupted by stop codons.  OrfM finds and prints these ORFs.")
 (define-public python2-pbcore
   (package
     (name "python2-pbcore")
-    (version "0.9.3")
+    (version "1.2.8")
     (source (origin
               (method url-fetch)
-              (uri (string-append
-                    "https://github.com/PacificBiosciences/pbcore/archive/"
-                    version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (uri (pypi-uri "pbcore" version))
               (sha256
                (base32
-                "1z46rwjac93jm87cbj2zgjg6qvsgs65140wkbbxsvxps7ai4pm09"))))
+                "02pfn5raa3zf739672bg0dkx7z3j2c4nx7vmpfjqy5b12jrqpymk"))))
     (build-system python-build-system)
     (arguments `(#:python ,python-2)) ; pbcore requires Python 2.7
     (inputs
@@ -2525,7 +2523,10 @@ interrupted by stop codons.  OrfM finds and prints these ORFs.")
        ("python-pysam" ,python2-pysam)
        ("python-h5py" ,python2-h5py)))
     (native-inputs
-     `(("python-setuptools" ,python2-setuptools)))
+     `(("python-docutils" ,python2-docutils)
+       ("python-nose" ,python2-nose)
+       ("python-setuptools" ,python2-setuptools)
+       ("python-sphinx" ,python2-sphinx)))
     (home-page "http://pacificbiosciences.github.io/pbcore/")
     (synopsis "Library for reading and writing PacBio data files")
     (description