summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorzamfofex <zamfofex@twdb.moe>2023-06-14 09:48:47 -0300
committerLudovic Courtès <ludo@gnu.org>2023-07-07 15:30:22 +0200
commit11d4a7152ecf5636c05da07f2f7be28b7620e348 (patch)
tree26f5478d27c8e206dc818db8a315d2b7f3f14903 /gnu
parent2e865166eafe282f4df33921df056b2294966fb7 (diff)
downloadguix-11d4a7152ecf5636c05da07f2f7be28b7620e348.tar.gz
gnu: Add ghc-these-lens.
* gnu/packages/haskell-xyz.scm (ghc-these-lens): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 3beb2c4cda..4af52a5bec 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -6410,6 +6410,27 @@ possible.  The library exposes a van Laarhoven interface.  For an alternative
 interface, supporting an opaque optic type, see @code{generic-optics}.")
     (license license:bsd-3)))
 
+(define-public ghc-these-lens
+  (package
+    (name "ghc-these-lens")
+    (version "1.0.1.2")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "these-lens" version))
+              (sha256
+               (base32
+                "1v3kj7j4bkywbmdbblwqs5gsj5s23d59sb3s27jf3bwdzf9d21p6"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "these-lens")))
+    (inputs (list ghc-these ghc-lens))
+    (arguments
+     `(#:cabal-revision ("2"
+                         "1mncy6mcwqxy4fwibrsfc3jcx183wfjfvfvbj030y86pfihvbwg3")))
+    (home-page "https://github.com/haskellari/these")
+    (synopsis "Lenses for These")
+    (description "This package provides Prism and Traversals for @code{These}.")
+    (license license:bsd-3)))
+
 (define-public ghc-libffi
   (package
     (name "ghc-libffi")