summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:45:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:23 +0200
commit1810b5b12d3ad123294e88caf46c0f12c1943544 (patch)
tree9e15103eab7098aee714e6dd9036828e953a6680 /gnu
parent72ab0870fa4cb764e79c253984042ef2eb1f09c2 (diff)
downloadguix-1810b5b12d3ad123294e88caf46c0f12c1943544.tar.gz
gnu: Add texlive-compare.
* gnu/packages/tex.scm (texlive-compare): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5ed94cd03a..e53c3f9ab9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1428,6 +1428,25 @@ Interfaces for Plain TeX, ConTeXt and LaTeX are provided.")
      "This package provides support for colour separation when using Dvips.")
     (license license:public-domain)))
 
+(define-public texlive-compare
+  (package
+    (name "texlive-compare")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "tex/generic/compare/")
+             (base32
+              "0isr7gmskv55cr4f1fa7s478v6fh65q9ijxkmbpxj0448g9817w4")))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/compare")
+    (synopsis "Compare two strings")
+    (description
+     "The file defines a macro @code{\\compare}, which takes two arguments;
+the macro expands to @samp{-1}, @samp{0}, @samp{1}, according as the first
+argument is less than, equal to, or greater than the second argument.  Sorting
+is alphabetic, using ASCII collating order.")
+    (license license:public-domain)))
+
 (define-public texlive-dosepsbin
   (package
     (name "texlive-dosepsbin")