summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-02 22:13:08 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-02 22:13:08 +0100
commit21df702808a8f4491e1ef5badc607748288fa69a (patch)
treef51c5a34a0d18f938eb9c60ff5bb42988e60ac2a /gnu
parent98c4f108f2f34ba4e333a0017e69d164ec3502e2 (diff)
downloadguix-21df702808a8f4491e1ef5badc607748288fa69a.tar.gz
gnu: qview: Update to 4.0.
* gnu/packages/image-viewers.scm (qview): Update to 4.0.
[arguments]: Append PREFIX to qmake call.  Fix auto-update removal.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/image-viewers.scm21
1 files changed, 7 insertions, 14 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 05e09263a0..b376f8ab72 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -495,7 +495,7 @@ For PDF support, install the @emph{mupdf} package.")
 (define-public qview
   (package
     (name "qview")
-    (version "3.0")
+    (version "4.0")
     (source
      (origin
        (method git-fetch)
@@ -504,29 +504,22 @@ For PDF support, install the @emph{mupdf} package.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "15a91bs3wcqhgf76wzigbn10hayg628j84pq4j2vaxar94ak0vk7"))))
+        (base32 "15n9cq7w3ckinnx38hvncxrbkv4qm4k51sal41q4y0pkvhmafhnr"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (replace 'configure
-           (lambda _
-             (invoke "qmake")))
-         ;; Installation process hard-codes "/usr/bin", possibly
-         ;; prefixed.
-         (add-after 'configure 'fix-install-directory
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
-               (substitute* "Makefile"
-                 (("\\$\\(INSTALL_ROOT\\)/usr") out))
-               #t)))
-         ;; Don't phone home or show "Checking for updates..." in the
-         ;; About menu.
+               (invoke "qmake" (string-append "PREFIX=" out)))))
+         ;; Don't phone home or show "Checking for updates..." in the About
+         ;; menu.
          (add-before 'build 'disable-auto-update
            (lambda _
              (substitute* "src/qvaboutdialog.cpp"
-               (("ui->updateLabel->setText\\(updateText\\);") "")
-               (("requestUpdates\\(\\);") ""))
+               (("qvApp->checkUpdates();") "")
+               (("updateText();") ""))
              #t)))))
     (inputs
      `(("qtbase" ,qtbase)