summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-05-06 14:27:36 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-05-06 14:36:08 +0300
commit22b794a4a7df724b41a6e17897bf47136dd1857a (patch)
tree24cb7b7d699e9dae8d0c3c1dab35bcbb48fbf94d /gnu
parentd540c6792b0ca8830c93505fc72647a21be2b230 (diff)
downloadguix-22b794a4a7df724b41a6e17897bf47136dd1857a.tar.gz
gnu: links: Use gexps.
* gnu/packages/web-browsers.scm (links)[arguments]: Rewrite using gexps.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web-browsers.scm33
1 files changed, 17 insertions, 16 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 2632ba257b..198d289ef3 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -167,23 +167,24 @@ management, extensions such as advertisement blocker and colorful tabs.")
                 "1jy90k04kl7y3l8jzg5jx7fglyqzngng0964j7j67gjxy9vkanzh"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:configure-flags '("--enable-graphics")
+     (list
+       #:configure-flags #~(list "--enable-graphics")
        #:phases
-       (modify-phases %standard-phases
-         (replace 'configure
-           (lambda* (#:key outputs (configure-flags '()) #:allow-other-keys)
-             ;; The tarball uses a very old version of autoconf. It doesn't
-             ;; understand extra flags like `--enable-fast-install', so
-             ;; we need to invoke it with just what it understands.
-             (let ((out (assoc-ref outputs "out")))
-               ;; 'configure' doesn't understand '--host'.
-               ,@(if (%current-target-system)
-                     `((setenv "CHOST" ,(%current-target-system)))
-                     '())
-               (setenv "CONFIG_SHELL" (which "bash"))
-               (apply invoke "./configure"
-                      (string-append "--prefix=" out)
-                      configure-flags)))))))
+       #~(modify-phases %standard-phases
+           (replace 'configure
+             (lambda* (#:key outputs (configure-flags '()) #:allow-other-keys)
+               ;; The tarball uses a very old version of autoconf. It doesn't
+               ;; understand extra flags like `--enable-fast-install', so
+               ;; we need to invoke it with just what it understands.
+               (let ((out (assoc-ref outputs "out")))
+                 ;; 'configure' doesn't understand '--host'.
+                 #$@(if (%current-target-system)
+                       #~((setenv "CHOST" #$(%current-target-system)))
+                       #~())
+                 (setenv "CONFIG_SHELL" (which "bash"))
+                 (apply invoke "./configure"
+                        (string-append "--prefix=" out)
+                        configure-flags)))))))
     (native-inputs (list pkg-config))
     (inputs
      (list gpm