summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2021-03-30 01:27:31 -0400
committerJelle Licht <jlicht@fsfe.org>2021-04-02 18:04:22 +0200
commit23ea84cdf07c9b6bd4a61d14e5cb6009060f87cf (patch)
tree140c29221307c0de526c0008110339ab3631235a /gnu
parent532c0e745aa81b5ac5ed8cb2b4f9b02aa720d9a9 (diff)
downloadguix-23ea84cdf07c9b6bd4a61d14e5cb6009060f87cf.tar.gz
build-system: Rewrite node build system.
* guix/build/node-build-system.scm: Rewrite it.
* guix/build-system/node.scm: Adjust accordingly.
* gnu/packages/node-xyz.scm (node-semver): Likewise.

Co-authored-by: Timothy Sample <samplet@ngyro.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/node-xyz.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index b1d6d4ce59..60cc005ea4 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -261,7 +261,11 @@ function with browser support.")
                 "06biknqb05r9xsmcflm3ygh50pjvdk84x6r79w43kmck4fn3qn5p"))))
     (build-system node-build-system)
     (arguments
-     `(#:tests? #f)) ;; FIXME: Tests depend on node-tap
+     '(#:tests? #f ; FIXME: Tests depend on node-tap
+       #:phases
+       (modify-phases %standard-phases
+         ;; The only dependency to check for is tap, which we don't have.
+         (delete 'configure))))
     (home-page "https://github.com/npm/node-semver")
     (synopsis "Parses semantic versions strings")
     (description