summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-18 21:23:14 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:56 -0400
commit2c30237809f975dbdf40d503fc9604de0013b870 (patch)
tree7cb7c82e71bc6705e1f435a86e745ea20dc17b75 /gnu
parent5fcd6aefe9ff972145401bcc927b597b182a2294 (diff)
downloadguix-2c30237809f975dbdf40d503fc9604de0013b870.tar.gz
gnu: python-sparqlwrapper: Update to 2.0.0.
* gnu/packages/rdf.scm (python-sparqlwrapper): Update to 2.0.0.
[source]: Adjust Git URI.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/rdf.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index e3a26cf734..826330585d 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -8,6 +8,7 @@
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 pukkamustard <pukkamustard@posteo.net>
 ;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -473,24 +474,20 @@ C++ library as well as various command-line tools to to work with HDT.")
 (define-public python-sparqlwrapper
   (package
     (name "python-sparqlwrapper")
-    (version "1.8.5")
+    (version "2.0.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                     (url "https://github.com/RDFLib/sparqlwrapper.git")
+                     (url "https://github.com/RDFLib/sparqlwrapper")
                      (commit version)))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1ia5h06zf6kpw6gdi7f80pzx10m79brj08zrbffb5wn9hzz8x528"))))
+                "1b4vg754kcxvinwdv7pjfmwbnmgm50w8mb2naf2lwp27bpyllvkb"))))
     (build-system python-build-system)
     (arguments
      '(#:tests? #f)) ; The test suite simply queries external HTTP endpoints.
-    (native-inputs
-     ;; Build with setuptools <58 to get lib2to3 support.
-     (list python-nose python-setuptools))
-    (propagated-inputs
-     (list python-rdflib))
+    (propagated-inputs (list python-rdflib))
     (home-page "https://rdflib.dev/sparqlwrapper/")
     (synopsis "SPARQL Endpoint interface to Python")
     (description "Python wrapper around a SPARQL service.  It helps in creating