summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-12-14 17:09:48 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2018-12-14 23:32:39 +0100
commit315956895173bdbe54f18ac8938ad1b70f7ef93b (patch)
tree6aee860802ad95d2c57e932a150fe7c163e7966e /gnu
parent1d9ce461f278c050e6ac93358ce74e2b85eb73a0 (diff)
downloadguix-315956895173bdbe54f18ac8938ad1b70f7ef93b.tar.gz
gnu: Add texlive-bibtex.
* gnu/packages/tex.scm (texlive-bibtex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 90dcf96858..5763a8c653 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5054,3 +5054,39 @@ TeX).")
     (synopsis "Fonts for XY-pic")
     (description "This package provides the XY-pic fonts.")
     (license license:gpl3+)))
+
+(define-public texlive-bibtex
+  (package
+    (name "texlive-bibtex")
+    (version (number->string %texlive-revision))
+    (source
+     (origin
+       (method svn-fetch)
+       (uri (svn-reference
+             (url (string-append "svn://www.tug.org/texlive/tags/"
+                                 %texlive-tag "/Master/texmf-dist/"
+                                 "/bibtex"))
+             (revision %texlive-revision)))
+       (file-name (string-append name "-" version "-checkout"))
+       (sha256
+        (base32
+         "1gk9q22fcb2fa1ql6cf9yw505x6a6axdzzfxbsya7nkrph860af8"))))
+    (build-system trivial-build-system)
+    (arguments
+     `(#:modules ((guix build utils))
+       #:builder
+       (begin
+         (use-modules (guix build utils))
+         (let ((target (string-append (assoc-ref %outputs "out")
+                                      "/share/texmf-dist/bibtex")))
+           (mkdir-p target)
+           (copy-recursively (assoc-ref %build-inputs "source") target)
+           #t))))
+    (home-page "https://www.ctan.org/pkg/bibtex")
+    (synopsis "Process bibliographies for LaTeX")
+    (description
+     "BibTeX allows the user to store his citation data in generic form, while
+printing citations in a document in the form specified by a BibTeX style, to
+be specified in the document itself (one often needs a LaTeX citation-style
+package, such as @command{natbib} as well).")
+    (license license:knuth)))