summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-09 09:13:51 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:59 +0200
commit3a6a5d1661cc6ea064a8cbbc954036e7b2be36b8 (patch)
tree02da898703cf0423e106cc7f9f21ca71f28344ee /gnu
parent6eb4a3e4925450be9cb08c9f624be8d495e198e1 (diff)
downloadguix-3a6a5d1661cc6ea064a8cbbc954036e7b2be36b8.tar.gz
gnu: Add texlive-ltxmisc.
* gnu/packages/tex.scm (texlive-ltxmisc): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 619ddcdb67..dcde3a0a9e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9050,6 +9050,32 @@ plain TeX.")
 
 (define-deprecated-package texlive-generic-ltxcmds texlive-ltxcmds)
 
+(define-public texlive-ltxmisc
+  (package
+    (name "texlive-ltxmisc")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "tex/latex/ltxmisc/")
+             (base32
+              "14llkpla8gpx7q6a53sd8a0a42wgk93fg4mbl6pc0v7v1kjblr5m")))
+    (build-system texlive-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'delete-non-free-file
+                 ;; This file has a non-commercial license.
+                 (lambda _ (delete-file "tex/latex/ltxmisc/vrbexin.sty"))))))
+    (home-page "https://ctan.org/pkg/ltxmisc")
+    (synopsis "Miscellaneous LaTeX packages")
+    (description
+     "This package provides miscellaneous LaTeX packages and classes.")
+    (license (list license:public-domain ;beletter.cls
+                   license:gpl2+         ;bibcheck.sty
+                   license:lppl          ;iagproc.cls
+                   (license:fsf-free "file:/linsys.sty")
+                   license:lppl1.0+)))) ;topcapt.sty
+
 (define-public texlive-pdfescape
   (package
     (name "texlive-pdfescape")