summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:49:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:28 +0200
commit4575ae283fbc425f434670f9d1a672ccbacf1c8a (patch)
tree8e4223654e3a22637ea4f86ea67e4146de4faae2 /gnu
parentc7e08aa26fd35bc965693d24b3931f0a5b7f2b25 (diff)
downloadguix-4575ae283fbc425f434670f9d1a672ccbacf1c8a.tar.gz
gnu: Add texlive-figflow.
* gnu/packages/tex.scm (texlive-figflow): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 787c1dcc30..3921b1c7d9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2496,6 +2496,30 @@ register.  The packages require the e-TeX extensions; with them, they work
 either with Plain TeX or with LaTeX.")
     (license license:lppl)))
 
+(define-public texlive-figflow
+  (package
+    (name "texlive-figflow")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/plain/figflow/" "tex/plain/figflow/")
+             (base32
+              "1vsrsw5rrqjym0flca9537m41vs7wlk8mhl9zmqjfaxgi8jvc9ml")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/figflow")
+    (synopsis "Flow text around a figure")
+    (description
+     "This package provides a Plain TeX macro @code{\\figflow} that allows one
+to insert a figure into an area inset into a paragraph.  Command arguments are
+width and height of the figure, and the figure (and its caption) itself.  The
+package does not work with LaTeX; packages such as @code{wrapfig},
+@code{floatflt} and @code{picins} support the needs of LaTeX users in this
+area.")
+    ;; README states: "You may freely use, modify, and/or distribute this
+    ;; file, without limitation."
+    (license (license:fsf-free "file://doc/plain/figflow/README"))))
+
 (define-public texlive-findhyph
   (package
     (name "texlive-findhyph")