summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 23:24:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:49 +0200
commit4c3237429436870cc7df57eadfe674f0a7bba6a3 (patch)
tree6cf6079be5179b40145ce2841fd0f048740aa9e8 /gnu
parentb91b5f41afd6f91804fec2343703ca285eb570e1 (diff)
downloadguix-4c3237429436870cc7df57eadfe674f0a7bba6a3.tar.gz
gnu: texlive-letltxmacro: Refresh package definition.
* gnu/packages/tex.scm (texlive-letltxmacro): Remove SIMPLE-TEXLIVE-PACKAGE
call.
[propagated-inputs]: Add TEXLIVE-ETOOLBOX.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm46
1 files changed, 22 insertions, 24 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bd1981d45e..aebe698a5c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6831,30 +6831,28 @@ footnotes with symbols rather than numbers.")
 (define-deprecated-package texlive-latex-footmisc texlive-footmisc)
 
 (define-public texlive-letltxmacro
-  (let ((template (simple-texlive-package
-                   "texlive-letltxmacro"
-                   (list "doc/latex/letltxmacro/"
-                         "source/latex/letltxmacro/"
-                         "tex/latex/letltxmacro/")
-                   (base32
-                    "16bmwsng9p80jf78sdmib24apwnw3raw306cs1ms50z5s9dsfdby"))))
-    (package
-      (inherit template)
-      (outputs '("out" "doc"))
-      (arguments
-       (substitute-keyword-arguments (package-arguments template)
-         ((#:tex-directory _ '())
-          "latex/letltxmacro")
-         ((#:build-targets _ '())
-          #~(list "letltxmacro.dtx"))))
-      (home-page "https://www.ctan.org/pkg/letltxmacro")
-      (synopsis "Let assignment for macros")
-      (description
-       "TeX’s @code{\\let} assignment does not work for LaTeX macros with
-optional arguments, or for macros that are defined as robust macros by
-@code{\\DeclareRobustCommand}.  This package defines @code{\\LetLtxMacro}
-that also takes care of the involved internal macros.")
-      (license license:lppl1.3c+))))
+  (package
+    (name "texlive-letltxmacro")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/letltxmacro/"
+                   "source/latex/letltxmacro/"
+                   "tex/latex/letltxmacro/")
+             (base32
+              "16bmwsng9p80jf78sdmib24apwnw3raw306cs1ms50z5s9dsfdby")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-etoolbox))
+    (home-page "https://ctan.org/pkg/letltxmacro")
+    (synopsis "Let assignment for LaTeX macros")
+    (description
+     "TeX's @code{\\let} assignment does not work for LaTeX macros with
+optional arguments or for macros that are defined as robust macros by
+@code{\\DeclareRobustCommand}.  This package defines @code{\\LetLtxMacro} that
+also takes care of the involved internal macros.")
+    (license license:lppl1.3+)))
 
 (define-deprecated-package texlive-latex-letltxmacro texlive-letltxmacro)